Problem uploading art and missing "Upload" button.

posted by CrumblinCookie • 3 years ago

Hey everyone!

I started my store a couple of days ago (thank you DBH for accepting my request!) and I managed to upload 4 designs that were accepted and are now displayed in my store.
Now I tried to upload another design but with no luck.
In Safari and Firefox the button to upload the art doesn’t show:

In Internet Explorer the button does show but when I try to upload I get http error 503.

In Chrome, which I used previously to upload my first 4 designs, the button is displayed, I can upload the art and set size and placement, and then I continue to the last page where I submit title and description, accept the terms and then click the button to submit. After that a blank page is displayed and from what I see the design is not submitted.
I tried it at least 5 times, with restarting the laptop and clearing cache.
I use Windows 7, internet browsers are up to date, all extensions are turned off.

Can anyone help me with that? Or at least check if everything is OK with my account? I would very much appreciate that.

39 Replies

CrumblinCookie CrumblinCookie Human from Poland

RavenTower, have you tried clearing cache? It didn’t help me with this problem but once when buttons did not work in my facebook account I cleared cache and it helped.

Vinehouse15 Vinehouse15 Artist from NY, United States

I tried that still not working. This site is just a glitchy nightmare. I wonder if it is because I signed up and registered on this site during the overhaul. I have had nothing but problems in all aspects of this site. Even just my default gallery isn’t showing up. Not trying to be a pain but it’s just VERY annoying. Been MONTHS now with these glitches.

kharmazero kharmazero Artist from France

i also have now a problem for uploading new works.2 months ago it was working perfectly fine on google chrome.My own little issue is when i click on the add a new product, i stay stucked on the dashboard page.I am running a OSX snow leopard.I have emptied the browser cache,resetted the default preferences to see what happened, and tried it using firefox and safari.Recently the adobe flash player has been updated.Nothging has worked so far.I’m out of solutions now.

Vinehouse15 Vinehouse15 Artist from NY, United States

It seems to work now….I think there are major issues with Google Chrome sadly. I tried things in Firefox and everything seemed to work….Hope this helps…

Inked Inked Human from California, United States

We started doing server upgrades overnight, so uploads might be glitchy throughout the first half of the day. Regarding RavenTower’s gallery comment, that’s not a glitch. We know it’s broken, we’ve just decided not to put the time into fixing it as is since we decided to incorporate it into something else we’re designing.

Vinehouse15 Vinehouse15 Artist from NY, United States

Cool thanks for ALL the feedback. You guys are fast with responses. GREATLY appreciated. :)

CrumblinCookie CrumblinCookie Human from Poland

I’ve managed to upload some designs from my laptop without any problems.
I didn’t change anything on my computer so maybe DBH fixed something. I also tried to upload and set size, placement, etc. as fast as I could to avoid a time-out. Don’t know if it had any impact but if any of you have problems like I did you may try to upload and submit as fast as possible too.

Thank you everyone for help and advice!

kharmazero kharmazero Artist from France

still not working for me ;(((

Bonvoyage Bonvoyage Artist from Korea, Republic of

I can’t upload new file. error message- IO Error(use IE,firefox,Crome)

Inked Inked Human from California, United States

If you’re having issues, please email your PNG to with your name (username) and a description of the error or what happens when you attempt to upload it so we can test with the same file you are using.


cabinsupplyco cabinsupplyco Human from otago, New Zealand

i have just signed up to this website, and i have to say iv found it almost impossible to use, iv had no problems uploading and editing files on other similar sites, in fact i find it really easy, but i just can’t grasp you guys uploading/editing process, why is it so complicated and yes also finding it quite glitchy, i’l give it another go at some point but for today I’m giving up, its just making me angry

Inked Inked Human from California, United States

What do you find impossible to use? We offer more options and customization than anyone else, so there is more things to select.

Any feedback would be great, but specifics are always very helpful.

cabinsupplyco cabinsupplyco Human from otago, New Zealand

thanks for replying, I’m finding it frustrating to use, it may be that its just different from what I’m used to, I’m going to try it again later and i’l reply with specific issues I’m having

CrumblinCookie CrumblinCookie Human from Poland

Is there a way to unsubscribe from this thread? I created it a year ago, the problem has been solved. But I still get an email notification every time someone writes a comment. Or maybe this thread can be just deleted? The problem doesn’t occur anymore.

dyronl dyronl Human from Oregon, United States

Hate to necro an old thread, but this issue still exists for Chrome. No upload button anywhere, and I’ve forgotten the URL I usually use to upload new products.

CassieDBH CassieDBH Staff from California, United States

@dyroni- it sounds like your session may have timed out. Try logging out of and back into your account and your upload button should reappear. If you’re still running into issues, please email us at

biotwist biotwist Artist from new jersey, United States

I have the same problem. I can only upload in chrome. in firefox the option to upload art just isnt there

KennefRiggles KennefRiggles Human from NY, United States

@CassieDBH this issue exists for me, but in Opera. chrome works, but on a fresh login to Opera i get no upload button.

refreshes and logging out and back in do not resolve. thoughts?

biotwist biotwist Artist from new jersey, United States

there has never been a point where this site has not been broke

Please log in to add your comment.